Jetstrap – The Bootstrap Interface Builder

Meet your new favorite web tool.

Watch how easy it is to get a high fidelity, beautiful responsive web page up and running. Drag-and-drop a large set of official Bootstrap components right to your page. You’ll be pounding out awesomeness in no time.

Watch the video

this is teh awesome! forget your wireframing, this is it! based on twitter’s bootstrap js lib

Advertisements

some bragging

Today, my new matias keyboard arrived. Time to show off my awesome, no teh awesomest setup evar!

Photo

First, there sits my MacBook Pro (mid 2009), now equipped with a Crucial M4 SSD (which leaves the DVD drive now hogging another USB port), which still makes it a lightning fast super machine (and makes that cooler pad a necessity, aside from that awesome blueish glow). In the front you can marvel at my new matias quiet pro. Now for some thunderbolt displays..

How to completely mess up an otherwise solid product [Update]

Yeah, its ranting time. This time for real.

I like companies like Cultured Code. They’re small teams with high visions and polished products. Gaining fame and good karma from guys like me, who buy all those awesome productivity tools to save the hassle of mundane things.

Apropos, things. Good example. Its nothing I can’t live without, but got used to it. Mainly used it to remind me of certain recurring things. Paid a bunch of coins for it. Not a fortune, mind you. But significantly more, than for the average below-2€-app. Thought it was worth it.

Then the product got enhanced, effectively replacing versions 1 with versions 2. No problem on the desktop, easy thing. Big hassle on the mobile side as it turns out. And that really stinks.

Here’s the shitstorm I heaved upon them:

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Hello there, I'm kind of a long-term user, bought the
iPhone-App ages ago, used it well along with the desktop app.
I'm still owning the very same>>iPhone 3G<<, mind
you.
Some time ago the iOS app stopped syncing whatsoever, guess
because you guys switched to a cloud-base-sync, effectively
disabling the old one.
Fine, so I upgrade the iOS-App, except its still up-to-date.
Ok,delete and reinstall.
Which epicly and totally failed, because suddenly Things
requires iOS 5 or later.
Dudes, wtf? Do I really have to buy a fucking new phone just to
use a fucking simple to-do-list-managing-thingie, which I bought
for just that simple case?! Are you serious? Just do that damned
thing downwardly compatible, as every sane developer would do!
How hard is that?!
And that isn't solved by an awkward series of steps to execute
(hidden behind an awkward series of FAQ&A links) to reenable
bonjour-sync.How do I get back that app? And don't tell me
to mine that out of my backups.

a disgruntled ex-customer
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Well, we’ll see how that ends. Until then, I’m looking for simple desktop-mobile-to-do-list-management.

Update

This is the response I got. Well, no news really..

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Sorry to have disappointed you.
Unfortunately, for technical reasons,
we can no longer support
iOS versions older than 5 (we dropped iOS 4 on August 9). 
In addition,Apple only allow us to offer the most recent
version of Things through
the App Store; when we update the app, it updates for
all users on all stores – we have no other option.
> And how do I get back that app? And don’t tell me to 
> mine that out of my backups.
That is the only way you can get the Things.ipa file back – 
we keepcopies of them here for our testing, but they are
associated with our Apple ID and wouldn’t work on another
person’s device. I’m sorry that you have been inconvenienced
by this, but unfortunately there’s no way for us to
distribute older versions of the apps – it’s
all under Apple’s control.
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

On the other hand, I can’t find a single reason, why to just drop older iOS versions from the production tool chain. Is it really that hard to maintain downwards compatibility for native iOS apps? Is Apple really the stinker here?